Protecting against the POODLE

At Ekaya we take security very seriously. When news of a new security threat, innocuously named POODLE, was announced yesterday we dove right in. We researched the flaw, looked at many pictures of poodles and secured our servers against it. (if you want to geek out, like we did, here is the full breakdown of the POODLE vulnerability)

We learned that POODLE does not only affect websites, it can also affect a user’s browsers if they browse a website with malicious intentions. In the interests of making your journey on the web safer please follow the instructions on the website below to defend your browser against the POODLE.

https://zmap.io/sslv3/browsers.html

You might need to refresh your browser a few times after making the change to see the secure sign.

Once you’re done there you can double check on this site:

https://www.poodletest.com/

Safe browsing!